HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Having problems with permissions in catalogs

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#70273 (In Topic #14876)
Avatar

Community saint

I had this working okay with galleries but now I have decided to use catalog.

My regular members should be able to add entries to one specific catalog (Image Gallery). But they don't get the "Add entry" link on the 'Catalog view' page. I have checked the privileges in cms:module:cms catalogs and in the specific catalogs under welcome:module:catalogs. All member have the view and the "Add catalog entry" privilege set. Can anyone think of what I am missing? There must be a privilege that I am overlooking.

Thanks for any help.

Bob
Back to the top
 
Posted
Rating:
#70277
Avatar

Community saint

Figured I would provide some visuals to help explain the problem. The following grabs are of the "Portrait" category view, a member of the 'Publisher' group on the left and a member of the 'Jr Member" group on the right - notice that the "Control functions are missing from the 'Jr Member':


Below is a grab of the permissions table for the "Portrait" category which is identical to its parent "Image Gallery" catalog.


I can't figure out why I am not getting the "Add catalog entry" for the member of 'Jr Member'. anyone see anything obviously wrong or have any other thoughts?

Thanks for any help.

Bob


Last edit: by BobS
Back to the top
 
Posted
Rating:
#70289
Avatar

I can't see anything wrong either. Some possibilities:
  • Member has been banned as a submitter
  • Category within Catalogue has overridden to not allow submission (assuming your screenshots are from the Catalogue)
  • Bug (but I tested and it worked ok for me)

If you put an empty writable file at data_custom/permissioncheckslog.php it will fill up with information on what permissions have been denied.

Or you can install Firebug and FirePHP and add this to the URL &keep_firephp=1 to see FirePHP logging the what permissions have been denied.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#70308
Avatar

Community saint

Issue resolved.

I had to grant "View access" to 'Zone: Content Management'. I need to test some more to see if this created other problems.

Bob
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: