HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Forum sidebar visibility problem

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#94756 (In Topic #18876)
Avatar

Fan in action

I setup two test ocPortal instances without any custom modifications.

one instance displays sidebar blocks in forum; the sidebar has Forums menu (forum home, private topics, undread posts etc), User menu (My profile, Logout...), Messages menu etc.

However, the second instance doesn't have this sidebar, although configurations are the same and comcode pages are not modified.

Consider that both sites have sidebar (panel_left) displayed in the zone editor (Admin > Structure > Block/panel layout (Zone Editor) > forum, but only one shows the sidebar in forum itself.
I've checked all other configurations in both instances, but can't find where to setup displaying panel_left in forum zone.

Does anybody has any suggestion where else I can check the settings in order to show/hide sidebar in forums?

Freelancing as a way of life
LoneShooter.com
Back to the top
 
Posted
Rating:
#94759
Avatar

Community saint

Hi LoneShooter,

You may have done this, but just in case:

1- Home-->Admin Zone-->Structure-->Zones-->Edit zone-->Forums-->Opt to hide the left/right navigation YES or NO.

2- Home-->Content Management-->Choose Edit Comcode page-->forum: panel_left / forum: panel_right
    These are separate Comcode panel pages from the Welcome panel pages. If empty, they will not show up.

Jean
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jean)  
Rating:
#94766
Avatar

Fan in action

Jean said

1- Home–>Admin Zone–>Structure–>Zones–>Edit zone–>Forums–>Opt to hide the left/right navigation YES or NO.


Well, the strange thing was that the option was the same on both sites "Respect member settings", and behaviors were different, even when I'm logged out. But never mind, I set the default value to "Yes" and this resolved problem. Thank you, Jean.

Freelancing as a way of life
LoneShooter.com
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: