HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Error when attempting to set smtp server info

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#26344 (In Topic #6116)
Avatar

Community saint

I went into the Configuration, Site Options menu and put in my smtp info, hit Proceed and got this error:

Forbidden

You don't have permission to access /community/adminzone/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.




 
Apache/1.3.34 Server at www.helpingpans.com Port 80

 
Back to the top
 
Posted
Rating:
#26382
Avatar

Community saint

Whenever I try to use the Site Configuration menu, I get the error above - Forbidden Access.  Consequently, I cannot open my site without using the Setup Wizard, also I cannot change some other settings that are only available there.  I checked the permissions for the Adminzone and for the Index file in Adminzone and both are set at 777.  

Suggestions?
Back to the top
 
Posted
Rating:
#26383
Avatar

Community saint

PS - I tried changing the permissions to 755, thinking maybe it was some kind of security block or something, but got the same error.
Back to the top
 
Posted
Rating:
#26388
Avatar

Look to see what the permissions are on your /site/index.php file, or perhaps your /index.php file, and then apply those permissions to the offending files.

Back to the top
 
Posted
Rating:
#26393
Avatar

Community saint

Thanks, I'll try that when I get home.
Back to the top
 
Posted
Rating:
#26433
Avatar

Community saint

Nope, that didn't work.  I tried every different setting available for the Adminzone and the Adminzone/index.php and nothing worked.  I also tried every combination of settings in the SMTP section and always got that exact same error.  
Back to the top
 
Posted
Rating:
#26435
Avatar

Community saint

Not only did this not work, but now I get an Internal Server Error and can't get into the Adminzone at all, even after changing the permissions back to where they were.  Sigh.  

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@helpingpans.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.34 Server at www.helpingpans.com Port 80
Back to the top
 
Posted
Rating:
#26436
Avatar

Community saint

I've just completed an exchange of nasty-grams with my web hosts about the dreaded Internal Server Error. They eventually fixed the problem, but not before I suggested it would probably make my life easier if I found a different web host.

The problem, certainly with my hosts, is that they've installed the mod_security module and haven't yet figured out how best to configure it to serve the ocPortal engine.

I'm not suggesting for a moment that your problem is the same, but it may pay to ask if they can look again at the filters they've set up for your account, and to relax them where necessary.

Give it a try. What have you got to lose?

 O_o

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#26437
Avatar

Community saint

I'll give it a shot.
Back to the top
 
Posted
Rating:
#26443
Avatar

Community saint

Nope, it isn't that.  The host says nothing shows up as a problem on their side.  They said the mod_security module would give a different error.  I'm at a complete standstill here!  Ugh.
Back to the top
 
Posted
Rating:
#26444
Avatar

Community saint

Sorry my 'suggestion' didn't work out.

I'll stop interfering and leave it to Chris or Philip, who may ask for access to your server to see what is amiss and, of course, they are the only ones that you can allow to go that route!

 :(

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#26445
Avatar

Community saint

They still have access since the last problem.  I'm hoping they'll check in with some ideas soon.  I really want to make this work for me, but it doesn't seem to want to.

:(
Back to the top
 
Posted
Rating:
#26449
Avatar

Community saint

I hope we can get it working too.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#26469
Avatar

Fletch was right – it's a dodgy security filter.

It's choking at two particular field values being passed through to the server:
  • one is HTML (the filter is trying to autodetect something called an 'XSS attack', but it is being paranoid to the extent where things that need to work don't)
  • one is a UNIX command (the filter is trying to autodetect some kind of attempt to run commands, but again, it's being paranoid)

These values are being passed through as part of ocPortal's configuration. It's vital ocPortal be able to configure key elements of HTML and commands used by the system. Blocking them is unreasonable, and your webhost should be lampooned.

Attachment
» Download: test.zip (1.26 Kb, 516 downloads so far)


The attached zip contains an HTML file which posts through the dodgy data to your server. Give it to your webhost and insist that this particular posted data is causing the Apache error. Feel free to use my explanation.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#26470
Avatar

I forgot to mention that 3 attempts to send in the blocked data to your website seems to block my IP address, and force me to reconnect to my ISP. I suspect that your webhost has some kind of setup that was doing that.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#26485
Avatar

Community saint

Okay, great.  I'll submit that and we'll see what happens!
Back to the top
 
Posted
Rating:
#26742
Avatar

Community saint

I haven't been having any trouble lately, but I hadn't done the one thing lately that so far has always given me an error, so I figured I'd go try it and see what happened.

This time when I went to Admin/Setup/Configuration/Site Options and clicked proceed, all I got was a blank page that said:

!

Should I report this as a bug?  Should I submit this to my host?  That's a new one.
Back to the top
 
Posted
Rating:
#26743
Avatar

I'd accidentally left some debugging code there. The fact that you saw it shows the initial problems is gone, and I've now removed that code.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#26744
Avatar

Community saint

Excellent!  It now works just fine.

Chris, you're a gentleman and a scholar.
Back to the top
 
Posted
Rating:
#27052

Non-joined user

re

 I have same problem..
Tried all permission combinations..
Then, I put "recommended.htaccess" and my error msg changed, from "Forbidden…etc etc" to Internal server error.
When I looked at my error logs, it says:

Code

 /home/ateljeb/public_html/.htaccess: Invalid command 'php_value', perhaps mis-spelled or defined by a module not included in the server configuration
Then I've commented lines with "php_value" command, but after that my error msg was "Forbidden…" again.

Any idea/tip please?
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand