HTML Logo by World Wide Web Consortium ( Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.

Internal Server Error

Login / Search

 [ Join | More ]
#47868 (In Topic #10430)

The web server is unable to load a specific URL.

How did this happen?

This is a particularly difficult error to diagnose. An error has occurred but the web server will not show anything more specific.

It could be caused by any of the following:
  1. Incorrect settings in a .htaccess file (e.g. references to settings the web server does not understand)
  2. You have a .htaccess file but your web host has prohibited them.
  3. Excess permissions on the directory a PHP script is in (e.g. putting 'world write' permissions on your 'htdocs'/'public_html'/'www' directory)
  4. Excess write permissions on the script being called up by URL
  5. You have 'mod_security' enabled and are trying to save your configuration, use the WYSIWYG editor, or edit a template.
  6. A fault on the server itself, such as PHP crashing.
  7. You're using 1&1 hosting and have exceeded the memory limit (they have a special version of PHP which cannot have memory limits set by code even though PHP-info claims otherwise, with these error messages if you exceed it instead of the normal memory error messages).

How do I fix it?

First identify the problem:
  • If you're on 1&1 hosting, you need to place php.ini files (1&1 use CGI PHP) that raise the memory limit, as described in the FAQ. You will not be able to raise beyond 30MB but that should be enough.
  • Try to see if you particularly identify with any of the other above causes, by thinking about recent changes you might have made, or any changes the web host has announced.
  • Analyse your web hosting error log for details.
  • (if you're stuck try trial-and-error)

  1. Try removing all lines from your .htaccess file and putting them back one-by-one (by editing in a text editor on your computer or from your web hosting control panel). This should help you narrow in on the line causing the problem.
  2. Discuss this with your web host. It is likely they have unintentionally removed your access to use this file (by changing/removing an 'AllowOverride' setting).
  3. Check for excess permissions and remove them.
  4. Check for excess permissions and remove them.
  5. Our default recommended.htaccess file has a clause in that can disable 'mod_security'. Place the obvious portion of the file into your own .htaccess file.
  6. Contact your web host.

If you are still not able to solve the problem contact your web host.

Last edit: by Chris Graham

Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
1 guests and 0 members have just viewed this: None