HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Error with new blog post

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#86467 (In Topic #17680)
Avatar

Honoured member

Hey guys,

I've been getting a strange error when i publish new blog posts. When i click the new blog from the "start" page i'm taken to the following error message;

Error Message said



02-Jun-2012 22:41:32 ocPortal Unfortunately a query has failed [INSERT INTO ocp_f_topics (t_pinned, t_sunk, t_cascading, t_forum_id, t_pt_from, t_pt_to, t_description, t_description_link, t_emoticon, t_num_views, t_validated, t_is_open, t_poll_id, t_cache_first_post_id, t_cache_first_post, t_cache_first_time, t_cache_first_title, t_cache_first_username, t_cache_first_member_id, t_cache_last_post_id, t_cache_last_time, t_cache_last_title, t_cache_last_username, t_cache_last_member_id, t_cache_num_posts, t_pt_from_category, t_pt_to_category) VALUES (0, 0, 0, 6, NULL, NULL, &#039;Comment: #news_1080&#039;, &#039;http://www.dietjustice.net/portal/index.php?page=news&amp;type=view&amp;id=sehbhundal-s-blog%2Fpanorama-have-we_3&amp;filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32&#039;, &#039;&#039;, 0, 1, 1, NULL, NULL, NULL, NULL, &#039;&#039;, &#039;&#039;, NULL, NULL, NULL, &#039;&#039;, &#039;&#039;, NULL, 0, &#039;&#039;, &#039;&#039;)] [<strong>Data too long for column 't_description_link' at row 1</strong>] (version: 8.1, PHP version: 5.2.17, URL: /portal/index.php?page=news&amp;type=view&amp;id=sehbhundal-s-blog%2Fpanorama-have-we_3&amp;filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32) @ http://www.dietjustice.net/portal/index.php?page=news&type=view&id=sehbhundal-s-blog%2Fpanorama-have-we_3&filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32



The fix is really odd. If i edit out the following from the URL, it fixes it;

&filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32

The URL minus the 'filter' works perfectly. Even stranger, when i go back to the 'start' page, and click the exact same link, it works immediately...even with the filter!

So first of all, is this a bug? and second, how do i get rid of these filters? I really hate them, they make URLs look messy. I've tried setting up the 'simple url' option but its way beyond my skill and its not within the support desk remit of my host.
Back to the top
 
Important!
Posted
Rating:
#86854
Avatar

Automated fix message

Ollie8557 said

Hey guys,

I've been getting a strange error when i publish new blog posts. When i click the new blog from the "start" page i'm taken to the following error message;

Error Message said



02-Jun-2012 22:41:32 ocPortal Unfortunately a query has failed [INSERT INTO ocp_f_topics (t_pinned, t_sunk, t_cascading, t_forum_id, t_pt_from, t_pt_to, t_description, t_description_link, t_emoticon, t_num_views, t_validated, t_is_open, t_poll_id, t_cache_first_post_id, t_cache_first_post, t_cache_first_time, t_cache_first_title, t_cache_first_username, t_cache_first_member_id, t_cache_last_post_id, t_cache_last_time, t_cache_last_title, t_cache_last_username, t_cache_last_member_id, t_cache_num_posts, t_pt_from_category, t_pt_to_category) VALUES (0, 0, 0, 6, NULL, NULL, &#039;Comment: #news_1080&#039;, &#039;http://www.dietjustice.net/portal/index.php?page=news&amp;type=view&amp;id=sehbhundal-s-blog%2Fpanorama-have-we_3&amp;filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32&#039;, &#039;&#039;, 0, 1, 1, NULL, NULL, NULL, NULL, &#039;&#039;, &#039;&#039;, NULL, NULL, NULL, &#039;&#039;, &#039;&#039;, NULL, 0, &#039;&#039;, &#039;&#039;)] [<strong>Data too long for column 't_description_link' at row 1</strong>] (version: 8.1, PHP version: 5.2.17, URL: /portal/index.php?page=news&amp;type=view&amp;id=sehbhundal-s-blog%2Fpanorama-have-we_3&amp;filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32) @ http://www.dietjustice.net/portal/index.php?page=news&type=view&id=sehbhundal-s-blog%2Fpanorama-have-we_3&filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32



The fix is really odd. If i edit out the following from the URL, it fixes it;

&filter=38%2C33%2C39%2C24%2C30%2C13%2C26%2C37%2C21%2C20%2C36%2C11%2C16%2C10%2C35%2C19%2C12%2C28%2C22%2C27%2C31%2C23%2C8%2C17%2C14%2C29%2C34%2C25%2C18%2C15%2C32

The URL minus the 'filter' works perfectly. Even stranger, when i go back to the 'start' page, and click the exact same link, it works immediately...even with the filter!

So first of all, is this a bug? and second, how do i get rid of these filters? I really hate them, they make URLs look messy. I've tried setting up the 'simple url' option but its way beyond my skill and its not within the support desk remit of my host.
This issue has been filed on the tracker as issue #575, with a fix.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Important!
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: