HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Error when attempting to Edit a menu499: missing ) after argument list

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#68575 (In Topic #14564)
Avatar

Fan in action

499: missing ) after argument list

I installed a new instance of ocP from ocportal_manualextraction_installer-6.zip on to a local Windows XAMPP web server. After setting the basic options, I'm getting an error when I try to edit a menu (either the zone menu or a left-block menu):

499: missing ) after argument list  http://..../themes/default/templates_cached/EN/javascript_more.js  After I clear the error message, the menu editor comes up and appears to work correctly…

I'm not too worried about the error because it seems to get over it just fine, but I'd like to start with a clean install without any lingering setup problems…
Back to the top
 
Posted
Rating:
#68576
Avatar

Ah rats, I thought this issue was a one-off (as I know some people upgraded fine) but you're the second to report it. see:
View topic: [RESOLVED] v6.1 - ocCLE error - ocPortal


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68578
Avatar

Community saint

I was just about to report a similar error while replying to any post on my forums.
No error reported for users, only admin.

Code

499: missing ) after argument list
http://....../themes/Web_2_0/templates_cached/EN/javascript_more.js
Just applied your patch and the problem is resolved.
Thanks
Back to the top
 
Posted
Rating:
#68581
Avatar

Well-settled

Well, and another one reporting it:


499: missing ) after argument list
http://www.alphaclan.org//themes/Wind/templates_cached/EN/javascript_more.js
Back to the top
 
Posted
Rating:
#68586
Avatar

Fan in action

I'm coming in on this new release, so I may be missing something, but…

I downloaded the JAVASCRIPT_MORE.tpl, copied it to my …/themes/default/templates_cache/EN folder but still get the same error.
Back to the top
 
Posted
Rating:
#68588
Avatar

Community saint

Andy Velasquez said

I'm coming in on this new release, so I may be missing something, but…

I downloaded the JAVASCRIPT_MORE.tpl, copied it to my …/themes/default/templates_cache/EN folder but still get the same error.
Andy,
You need to copy it to: /themes/default/templates/

The template_cache is being replaced by the templates files, so you loose the update.

Clear your cache by deleting the file you copied there or use Admin Zone > Tools > Website cleanup tools/Template cache
:)
Back to the top
 
Posted
Rating:
#68627
Avatar

Fan in action

Jean,
That did the trick.  Thanks!  
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: