HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Error in step 10 of setup wized

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#92147 (In Topic #18495)
Avatar

Fan in action

what does this message mean?

i got this error during step 10 of setup wizard

=================================

Critical error – bailing out

This is an error that has been elevated to critical error status because it occurred during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occurred before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.
Unfortunately a query has failed [SELECT main.*,t0.text_original AS t0__text_original,t0.text_parsed AS t0__text_parsed,t1.text_original AS t1__text_original,t1.text_parsed AS t1__text_parsed,t2.text_original AS t2__text_original,t2.text_parsed AS t2__text_parsed FROM c6x_f_member_custom_fields main LEFT JOIN c6x_translate t0 on t0.id=main.field_1 AND t0.language='EN' LEFT JOIN c6x_translate t1 on t1.id=main.field_6 AND t1.language='EN' LEFT JOIN c6x_translate t2 on t2.id=main.field_9 AND t2.language='EN' WHERE (main.mf_member_id=2) LIMIT 1] [Unknown column 'main.field_6' in 'on clause'] (version: 9.0.2, PHP version: 5.2.17, URL: /community/adminzone/index.php?page=admin_setupwizard&type=step10)
=============================================

this is the 3rd time i had to re-install my ocp site
but im not giving up
i think issue is more due to me not knowing how this works

first i could not delete forums
so i reinstalled
then the skydiver theme broke my site
so i reinstalled again
now the setup wizard went crazy on me
so yet again i had to reinstall

this cms has so many useful features included
but site breaks so easily, wow

im concerned if this cms is safe and stable to use on a seriouis project
all these reinstalling worries me
- in other cms things either work or not, but site remains fully functional
well, im still goin to hang in there and see

Im using ocPortal to create DisabilityForce.com - a place for disabled people (like me) to provide mutual support to each other, and in doing so, they are empowered to become more inclusive, successful, and contributing citizens in society. It is also for anyone who is supportive of the rights and pursuit of happiness of people with disabilities. So, on behalf of the 1.2 billion disabled people in the world, I humbly thank this community for all assistance received.
Back to the top
 
Posted
Rating:
#92158
Avatar

Hi,

first i could not delete forums

You need to be patient ;). I suspect you had set the forum as being the comments forum, or something like that, but a screenshot could have confirmed – and either led to a bug fix or a confirmation of how to resolve.

then the skydiver theme broke my site

As someone mentioned (I think it was Harry), this  is a version 8 theme which you installed on a version 9. Version 8 themes aren't compatible, and it would say in the breadcrumbs when browsing the theme that it is a version 8 one. In the past themes have generally been compatible with future versions, but this wasn't the case for v9. When you run the Setup Wizard it asks you to bookmark a Safe Mode link – this would have worked to get the default theme back, while you deleted the theme you'd added. Alternatively waiting for advice would have allowed someone to suggest a remedy, such as manually deleting the theme directory, putting &keep_theme=default in the URL to force usage of the default theme, going to the Admin Zone manually (usually custom themes are not applied to the Admin Zone), or activating Safe Mode. So again, patience while people respond :).

I understand the desire to get things done fast and not want to wait for help, but ocPortal is a big system that does a lot, so rushing too fast is likely to cause frustration more than anything (unless you're a programmer and used to learning new systems extremely fast).


This problem is a bit more tricky. I am not sure how you reinstalled (maybe restored via a backup, rather than re-running the installer?), but it looks to me like the f_custom_fields table was restored but the f_member_custom_fields table was not.


Last edit: by Chris Graham


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#92168
Avatar

Fan in action

Hi, thanks for your reply (and advise).

I reinstalled using Cpanel installer script.
All was fine, until I used the setup wizard.

Perhaps, I should of cleared my browser cache. Or, these things are common when internet is slow.

As of now, all is working fine (thank you, God!)… except

when you click on "read more" on a news article, the next screen displays the the first word of  the title, then the breadcrums, then the rest of the news article. Strange.

Im using ocPortal to create DisabilityForce.com - a place for disabled people (like me) to provide mutual support to each other, and in doing so, they are empowered to become more inclusive, successful, and contributing citizens in society. It is also for anyone who is supportive of the rights and pursuit of happiness of people with disabilities. So, on behalf of the 1.2 billion disabled people in the world, I humbly thank this community for all assistance received.
Back to the top
 
Posted
Rating:
#92173
Avatar

Community saint

Most of the time any problem with ocPortal can be resolved without a Re-Install. In fact as far as I have seen ocPortal works much better at resolving issues with less major headaches than most other CMS's. Of course the only headache is being patient and learning those tricks (or in some case waiting for those very fast bug fixes from the ocPortal Team). But if you run into a problem again I wouldn't re-install till you've asked and waited some time for answers from people cause usually you won't have to. You're problem with the title I answered in another thread.
Back to the top
 
Posted
Rating:
#92183
Avatar

I reinstalled using Cpanel installer script.

This is probably something I can't answer on. It may be a simplescripts installer issue, which we've found has been liable to being buggy – these kinds of third-party installers aren't usually something we have much control over, or any real way to test or debug.

Maybe for example the installer wipes out table rows instead of recreating tables fully, and some kind of counter ends up misset. If you continue to have a stack-trace style problem with the very earliest (re)installation stages it'd be best to identify the origin of the installer and post the name of it here, and then contact the programmers pointing them to this topic. That would hopefully start off some information sharing between them and us.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: