HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Deleting a PT gives error

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#90076 (In Topic #18235)
Avatar

Community saint

Trying to delete a PT resulted in this…

An error has occurred

Either you ("sholzy") have lost access between the time of the link you clicked appearing and now, you have found a bug, or you are jumping into URLs. (version: 8.1.3, PHP version: 5.3.8, URL: /forum/index.php?page=topics&type=_delete_posts&id=1658&keep
_fatalistic=1&mark_6502=1)

You have turned on stack traces for all errors, via having keep_fatalistic=1 in the URL. This means that this may not actually be a fatal error, you have just asked for it to be presented as such (perhaps to help you find where it came from).
Here is the stack trace:

Code

File    '/home/whiteisl/public_html/sources/failure.php'
Line    '698'
Function    'get_html_trace'
Args   

File    '/home/whiteisl/public_html/sources/global.php(213) : eval()\'d code'
Line    '985'
Function    '_fatal_exit'
Args   
object


File    '/home/whiteisl/public_html/sources/failure.php'
Line    '238'
Function    'fatal_exit'
Args   
object


File    '/home/whiteisl/public_html/sources/global.php(213) : eval()\'d code'
Line    '945'
Function    '_generic_exit'
Args   
object

'WARN_SCREEN'


File    '/home/whiteisl/public_html/sources/failure.php'
Line    '1,028'
Function    'warn_exit'
Args   
object


File    '/home/whiteisl/public_html/sources/permissions.php'
Line    '97'
Function    '_access_denied'
Args   
'I_ERROR'

''

false


File    '/home/whiteisl/public_html/sources/ocf_posts_action3.php'
Line    '209'
Function    'access_denied'
Args   
'I_ERROR'


File    '/home/whiteisl/public_html/forum/pages/modules/topics.php'
Line    '365'
Function    'ocf_delete_posts_topic'
Args   
1658

array ( 0 => 6502, )

''


Function    '_delete_posts'
Class    'Module_topics'
Object    Module_topics::__set_state(array( ))
Type    '->'
Args   

File    '/home/whiteisl/public_html/forum/pages/modules/topics.php'
Line    '158'
Function    'call_user_func'
Args   
array ( 0 => Module_topics::__set_state(array( )), 1 => '_delete_posts', )


File    '/home/whiteisl/public_html/sources/zones.php'
Line    '425'
Function    'run'
Class    'Module_topics'
Object    Module_topics::__set_state(array( ))
Type    '->'
Args   

File    '/home/whiteisl/public_html/sources/site.php'
Line    '1,045'
Function    'load_module_page'
Args   
'forum/pages/modules/topics.php'

'topics'


File    '/home/whiteisl/public_html/sources/site.php'
Line    '804'
Function    'request_page'
Args   
'topics'

true


File    '/home/whiteisl/public_html/forum/index.php'
Line    '51'
Function    'do_site'
Args   

Parameters

reason   
require__reason   
0

Anyone have a link to the bug catalog for 8.1.x? I've been hunting for it for several days. Since a non-current install won't show the link in the admin panel it makes it kinda hard to find fixes when bugs pop up.  :dry:

Also, the bug link in the 9.0 install goes to a non-existent page.

Steve
Back to the top
 
Posted
Item has a rating of 5 (Liked by sholzy)  
Rating:
#90078
Avatar

Community saint

Version 8.1.3 - ocPortal.com - (17 entries)

Version 9 - ocPortal.com - (20 entries)

Does that help?


Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#90079
Avatar

Community saint

Fletch said

Version 8.1.3 - ocPortal.com - (17 entries)

Version 9 - ocPortal.com - (20 entries)

Does that help?


Perfect! Thanks, Fletch! I have it bookmarked now.  :thumbs: I kept forgetting to do that before.

There are several fixes I need for 8.1.3 listed in there.  :)

Steve
Back to the top
 
Posted
Rating:
#90080
Avatar

Community saint

 :lol: Looks like we live in the same web-o-sphere as far as 'forgetting' to bookmark things. Especially when we know we've seen and used them before.

At least I have an excuse; AGE!

 :o

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#90081
Avatar

Community saint

me to, so thanks for the links Fletch  hahahahaha


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Item has a rating of 5 (Liked by sholzy)  
Rating:
#90088
Avatar

Main issue – this is a small bug based on the way you're managing the topic, you'll need to delete the topic as a whole (there's an action for that) for now rather than checking and deleting each separate post.

Broken v9 bugs link - fixed.

Missing v8 link – I've added a link to the main index of the bugs database to the support page of ocPortal.com.



Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90095
Avatar

Community saint

Chris Graham said

Main issue – this is a small bug based on the way you're managing the topic, you'll need to delete the topic as a whole (there's an action for that) for now rather than checking and deleting each separate post.

This wasn't a big deal to me. The "rogue" post I tried deleting was a copy of a post I was quoting and replying to. Except this "rogue" post didn't contain my reply. It's like it posted in the time between clicking the quote button and the time I started typing my reply. Same time stamp on both posts. I didn't even know it was there until I posted my reply. Just one of those weird anomalies I guess.

Broken v9 bugs link - fixed.

Missing v8 link – I've added a link to the main index of the bugs database to the support page of ocPortal.com.

Thanks, Chris.  :thumbs:

Steve
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: