HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Default editor to "No" on perform standards validation

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#26507 (In Topic #6144)
Avatar

Community saint

The deafult editor validates to correct post text to exact HTML code. This is a problem for new users

The WYSIWG editor is a wonderous piece of work however for the average punter the error essages confuse to the extent they often do not post and cancel the work wheras often if you just either preview and press "Add topic" the post presents perfectly even though there may be many html errors.

I have attached a typical example of a post like that.

Fix 1
Default the text "Perform standards validation when previewing:"  to NO
Fix 2
If you are doing full HTML Validation add a help page like the c symbol comcode page which tells you how to fix each of the HTML error lines.
I think FrontPage 2003 and Dreamweaver has all the HTML Tags explained in full and we could cut and paste the relevant TAG details into some sort of help file. Just a thought. They never change so done once it is there a long time.

PS I still cannot get the browse (So I can upload a file) button to unshade on every post until I post and then edit. Is that a permissions thing?

209 views (99 Kb)
Back to the top
 
Posted
Rating:
#26545
Avatar

I didn't realise it was so easy to create such problems using the WYSIWYG editor, but it's obvious now that you point it out.
In the next patch release, the preview validation will be defaulted to off for non-staff.

It took me a while to reproduce your upload issue. Now I see after previewing, you can't attach more files. This will be fixed in the next patch release.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#26574
Avatar

Community saint

OneringRules,

Thanks for clarifying what I was trying to say previously about this feature.

These errors are very easily reproduced and cause heartache to users that are not puter literate.

I have had to disable the feature so they can post without all the problems.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: