HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Custom Comcode tag - V9.0

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#90358 (In Topic #18264)
Avatar

Well-settled

Tag does not work when page saved.

Hi folks,
I'm back :)   (I'm loving the new V9)

I'm a little puzzled by something and perhaps someone could shed some light on the situation for me?

I created a custom comcode tag that uses Google's MP3 Player to embed a simple mp3 player.

The tag works great up until I save my work…

Example:
I create a blog and add the new tag into the blog > when I preview the blog the tag works as it should and plays the song.
When I save the blog the tag no longer works…….I don't know why?

BTW: I have tried the same method with similar mp3 players and I always get the same problem…they work great until I save.
Also I have done this exact same process in V8 and below and never had this problem.

Any thoughts?
Thanx
Gerald

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#90361
Avatar

Hard to answer this one… would need to actually look at the HTML of the live page to ascertain what was missing/incompatible in that context. Sounds to me like whatever the code is, it's too fragile to run on arbitrary pages, but this is a guess.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90362
Avatar

Well-settled

Hey Chris,
The site is closed because I'm still in the process of building it but I opened it so you can see.

This is the link to the page Interview with Popcorn - Tisnart World

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#90363
Avatar

Well a widget is there but the Chrome error log says Failed to load resource: the server responded with a status of 404 (Not Found) http://tisnart.com/world/site/uploads/filedump/Popcorn%20interview/popcornremix.mp3


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90372
Avatar

Well-settled

That's very confusing for me because why would it work in preview mode…..it must be able to load the file?

(Akkkkk!…my header has just disappeared)

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#90374
Avatar

It looks like you probably are referencing it as a relative URL, but this won't work well because in different directories relative URLs will always be different.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90377
Avatar

Community saint

Hi Tisnard welcome back. I visited your site and could play the popcorn mp3 without any problems with Opera browser.


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#90378
Avatar

Well-settled

I am indeed referencing it as a relative URL. (this is how I have done it in the past with no problems)

Yesterday I tried referencing it as both an absolute URL and a relative URL but had the same issues.
(thus I started this topic)

Ok, I attempted it again,
-Two mp3 widgets this time.
-The first one with absolute URL
-The second with relative URL
The result was both would play fine before I saved the page and only the first one would play after I saved.

Now I have made both of them with absolute URL and they are both working.

I'm confused…but it's working?

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#90379
Avatar

Well-settled

Harry-S said

Hi Tisnard welcome back. I visited your site and could play the popcorn mp3 without any problems with Opera browser.
Hi Harry,
That's probably cause I just got it to work.

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#90380
Avatar

Well-settled

Weird?
Since I opened my site I lost the header and outer_background images. When I checked the url had changed and was pointing to the images folder instead of the images_custom folder?

Maybe my site is under the forces of the dark side  :lol:

Making games is fun…having people play them is the reward!
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: