HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Couple of issues after upgrade to 8.0.1

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#85828 (In Topic #17606)
Avatar

Well-settled

Comments and block_rss

I'm having an installation ever since ocp4 that's being upgraded since then.
After 8.0.1 I've found these issues:

block_rss shows up ok in preview but in live site gives me this:

"This information has not loaded yet. It will be generated in the background, please come back later."

Code I'm using is

Code

[ block="http://www.rssmix.com/u/3049152/rss.xml" max_entries="2" title="News from RSS" ticker="0" quick_cache="0" ]side_rss[ /block ]

(wysiwig won't play nice with opera, added spaces in brackets and it replaced " with & quot; )
Bear in mind that I did place the block_side_rss.tpl from default ocp 8.0.1 into my templates_custom and cleaned all caches in case it worked, but it didn't work.

Another issue I'm having is with comments under catalogue entries or news posts. You can post something but after you hit "Make comment" it'll reload the page link but give you a blank screen. I need to manually hit refresh on my browser for the page to appear with the comments.
Back to the top
 
Posted
Rating:
#85829
Avatar

Well-settled

Also I get this error from time to time.

An error occurred when loading this screen onto the web browser. You are being notified of this as you are staff. If you believe this is a bug in the website software, please contact ocProducts with full details. More details are available in your browser's error console. The error was: 53: Uncaught exception: TypeError: Cannot convert 'l.lang.contextmenu' to object http://www.metal-temple.com/data/ckeditor/ckeditor.js

And most weird error I got just now:

People had problem to login. I copied all the block_side_personal_stats*.tpl files to my templates_custom and I was able to login from the welcome page. Problem is that when a guest visits the page, or I logout, I see the other admin's menu appearing in that block instead of the login form. I restarted apache and mysql, cleared everything using ocportal's tools, but nothing. :S

EDIT: did a repair/optimize in the tables and removed quick cache from the block. That seemed to fix the problem. Are there any other files in the templates I should upgrade from 7 to 8?

Also when I log in I can see the block_rss contents. When I log out I still get the error.


Last edit: by Palanthas
Back to the top
 
Posted
Rating:
#86018
Avatar

Hi,

1- RSS (Replied in your other topic)

2- Commenting. It should work by AJAX now. I wonder if you have some kind of template override. Try it with &keep_theme=default in the URL to test as per the default theme.

(replying to next post next)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#86019
Avatar

Okay…

I think the ckeditor problem must be a missing file somewhere. Try running the integrity checker in the upgrader.

Setting 'cache' explicitly on the side_personal_stats block would cause problems. That block doesn't define any caching signature at all (as it really is different for everyone), so this would make it automatically be the same for anyone.

Regarding RSS, I think that's the same issue as discussed before.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#86197
Avatar

Well-settled

Fixed the comments things.

Indeed I needed to delete the old comments.tpl (there since v4) and put in my templates_custom the following files from the default 8.1 theme:

CATALOGUE_DEFAULT_ENTRY_SCREEN.tpl
COMMENT_AJAX_HANDLER.tpl
COMMENTS_DEFAULT_TEXT.tpl
COMMENTS_POSTING_FORM.tpl
COMMENTS_WRAPPER.tpl

It works perfectly now!

Removing the quick cache sold the personal stats issue.

I'm still trying to figure out the RSS part. Did replace the zones.php file with the one you have, the had the same exact file size (guess you integrated it into 8.1 fix?) and I don't see any change. Will look into it though.  :thumbs:
Back to the top
 
Posted
Rating:
#86201
Avatar

8.1 should fix it, let us know if not.

We've now got a much better bug filing system that integrates git, the tracker, the bugs catalogue, and the forum – so fixes won't get lost again going forward.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: