HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Content stacked x2 or x3 or flashing quickly

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#57330 (In Topic #12465)
Avatar

Community saint

I am getting duplicated and triplicate description text in the thumbnail galleries

I am having a thumbnail gallery problem in the display of the image description. When I mouse over the thumbnail I get the description text displayed, It displays differently in IE & Firefox.

In IE it shows up mostly as duplicated text, and once in triplicate, stacked 3 times! Now if I move the mouse off and then back again it shows up as the description normal, that is not multiple stacks. Note all the stacks are in one box not multiple - only the text group is multiplied. So this is wierd, yes I think so. A browser issue?

Well in Firefox it usually display in what I would consider normal or natural. I did get a duplicate display as in IE but seems rare and another time once (so far) one content box hung on open and stuck, not to the curser but to the image space like it was held by electronic Vercro while the next one opened normally and displayed also. Neither one was stacked, single description text. The velcor one never did close till I left the thumbnail gallery.

The other Firefox oddity was when the curser moved over the thumbnail, the description FLASHED on quickly and sometimes would flicker like a dying flame and other times refused to make another appearance untill I moved the curser somewhere else then back again.

How wierd if this? I am hoping someone knows how to fix this one?


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#57334
Avatar

Community saint

friendly said

 I did get a duplicate display as in IE but seems rare and another time once (so far) one content box hung on open and stuck, not to the curser but to the image space like it was held by electronic Vercro while the next one opened normally and displayed also. Neither one was stacked, single description text. The velcor one never did close till I left the thumbnail gallery.
I got this to happen again in Firefox but still dont know what triggers it. Did exactly the same.

friendly said

The other Firefox oddity was when the curser moved over the thumbnail, the description FLASHED on quickly and sometimes would flicker like a dying flame and other times refused to make another appearance untill I moved the curser somewhere else then back again.
OK, so this one is maybe easier to understand what makes it happen. It only happens when the image description box is near the bottom edge of the screen. The one picture where I was noticing it the most was an image with a long description. I think the box tries to open but is bounded by some limit which wont allow the whole thing to appear. Everytime I move the cursor it tries to open again. If I scroll the screen display up to where there is more room it will open completely like the other 'normal' displays. Right, left and top margins don't seem to affect it only the bottom boundry and it is aggravated by longer description content which require taller boxes.

I did get IE to blink when the image was near the bottom screen edge finally, once I found out what set off the behavior. In IE it blinks rather than a flash like Firefox.

friendly said

In IE it shows up mostly as duplicated text, and once in triplicate, stacked 3 times! Now if I move the mouse off and then back again it shows up as the description normal, that is not multiple stacks.
After the first mousover multiple display if I go back to it it appears as I believe it was ment to, a box with a single description. No mater how many times I return to a thumbnail it is OK and appears normal. As soon as I leave the page and then return the same behavior will repeat itself.

Could this be some type of a cache issue?


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#57336
Avatar

Hi,

Thanks for the thorough report.

The main doubling-up problem is now fixed, the change is in themes/default/templates/JAVASCRIPT.tpl. Change:

Code

      ac.tooltip_on=true;

      setInnerHTML(tooltipElement,tooltip,true);
to:

Code

      if (!ac.tooltip_on) setInnerHTML(tooltipElement,tooltip,true);

      ac.tooltip_on=true;


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#57339
Avatar

Community saint

I am astounded! it worked perfectly. No more multiplied stacked descriptions.

Thank you once again Chris Graham.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: