HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


CEDI short urls

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#25388 (In Topic #5962)
Avatar

Well-settled

Hi,

If I use the recommended .htaccess I get an internal server error - yet strangely the site works with short urls without any .htaccess file?

Made the changes to sources/urls and now get a 404 error.

Have tried both plain and recommended .htaccess.



I no longer have a wiki.



D.
Back to the top
 
Posted
Rating:
#25389
Avatar

Well-settled

OK, tried sticking the plain access file back and undoing the changes, now I have a wiki again but no pages in my wiki

"The requested page ('cedi_page') is missing."


*sigh*


D

Back to the top
 
Posted
Rating:
#25390
Avatar

Well-settled

Interesting. For fun and frolics tried adding a new page.

It worked.

Just as well it wasn't a large well-established wiki.



D

Update: I say it worked, but now every one of my 'child' pages is the same blank page with the word 'test' on it. Is it worth trying to recreate pages or is this thing completely screwy?




Last edit: by dateofbirth
Back to the top
 
Posted
Rating:
#25393
Avatar

As explained in the documentation, short URLs can only work if your server is configured with the Apache mod_rewrite module. If you don't have that installed and configured so it can be controlled by .htaccess files, you cannot use short URLs.

Back to the top
 
Posted
Rating:
#25400
Avatar

Well-settled

Is that only affecting the cedi or does it create bugs elsewhere?

Because if it's a choice between my favorite hosting company and the cedi, the cedi is toast.



D
Back to the top
 
Posted
Rating:
#25401
Avatar

Well-settled

Hello,

"We support the Apache mod_rewrite. You can put mod_rewrite directives in .htaccess files.
If you need any additional information, please let us know.
Thank you.

Best Regards,
Support"

So put the recommended .htaccess file up, having renamed it…

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin@domain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."


I'll ask my host to check the logs.


Last edit: by dateofbirth
Back to the top
 
Posted
Rating:
#25403
Avatar

Well-settled

This is why I love my hosting company. In about 10 mins or so:

"PHP directives should not be placed in .htaccess files on our machines. Our servers are running Suexec, which is the most secure environment for a shared hosting server, because scripts are run with the credentials of your user and not with the user of the web server (apache).

Under Suexec, all PHP runs as CGI (not as a module) and all PHP directives should be placed in php.ini files.

You can create a php.ini file in the directory you need to use php directives. What is required is that you have the following lines always present in your php.ini files for compatibility reasons:

post_max_size = 20M
memory_limit = 80M
upload_max_filesize = 20M
max_execution_time = 120
expose_php=off

Have in mind that the php.ini files do not act recursively. You will need to place a copy of the php.ini file in each directory where you want the PHP behavior changed.

Please relay this information to the script developers and have them advise you on how you should proceed.

Best Regards,
Support"
Back to the top
 
Posted
Rating:
#25407
Avatar

In that case, plain.htaccess should work for you, as it has the mod_rewrite stuff, but not the PHP directives.

Back to the top
 
Posted
Rating:
#25411
Avatar

Well-settled

Weird, just opened my cedi to detail the errors and now it does indeed seem to work.

I'll try adding a new entry and see what happens.

I made the mistake of working on the site with no sleep last night (well, this morning) and didn't make backups of anything.

mmm, it all looks great, until I try to add a new entry, url is

http://www.domain.com/site/pg/cedi/post/1%2F5

and produces a 404

Is this because of the sources/urls change or something? Or something else?


D

Back to the top
 
Posted
Rating:
#25414
Avatar

Well-settled

Well if I put the /sources/urls back to how it was, I get a 404 error before it can even open a child page.

With the updated version I can view the child pages but not add new ones.

'elp!


D
Back to the top
 
Posted
Rating:
#25415
Avatar

CEDI short-URL problems were fixed a few releases ago, and are listed under the bug reports somewhere.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#25418
Avatar

Well-settled

Well it's not working on my installation.

If I click edit tree or add new post - I get a 404 error.

Asides from that it works great.  O_o
Back to the top
 
Posted
Rating:
#25419
Avatar

Well-settled

OK next question, how do I remove all traces or references to cedi, wiki, whatever, from the content management screen?

I don't have time to keep faffing about with this, either it works or it doesn't and this thing doesn't, so I want rid of it, completely.

How do I kill it?


D
Back to the top
 
Posted
Rating:
#25422
Avatar

Well-settled

Is this something to do with it:

A language entry is missing: DOC_CEDI_EDIT_PAGE (ocPortal version: 3.0.11, PHP version: 4.4.4, URL: /cms/pg/cms_cedi/misc)

That's what I get when I click cedi from the content management screen - it had this problem before I did the short urls. Is this what's causing the complete 404 no page error from the cedi itself?



D
Back to the top
 
Posted
Rating:
#25423
Avatar

You've hidden CMS icons for users before, by changing permissions. I'm 100% sure the bugs have been fixed, so probably you have some wrong file versions or have something overriding a bug fix. This language error is actually evidence of an incorrectly performed upgrade; as specified in the upgrade tutorial and with the patches, you need to clear caches. Either that, or the new lang/EN/cedi.ini file wasn't uploaded.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#25427
Avatar

Well-settled

 :$

Well I just updated that language file with the one from 3.0.13  and it's still 404 from the cedi itself, though it does allow editing from the CMS, I think.

Hard to tell, my connection is crawling right now and just opening a page takes 10 minutes, literally.

Make that 16 minutes, I'm still waiting for the edit page to load to see if it works.

Ho hum…

Zzzzzzzzzzzzz…….


Oh I can't be bothered, I'll try again tomorrow. It's 4.00am here

Back to the top
 
Posted
Rating:
#25428
Avatar

Well-settled

Mmm, other sites are loading OK, I think this thing is just hanging.

Could you explain, plain and simple, how exactly to do the permission thingy so no member sees the cedi icon on the CMS? Because I just end up with "view access only" which is exactly what I didn't want.


D
Back to the top
 
Posted
Rating:
#25430
Avatar

Untick the view access tick boxes in the site tree editor, under cms\cms_cedi. Click 'Set'.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: