HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Can't add an image to a gallery

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#57924 (In Topic #12644)
Avatar

Well-settled

"You did not provide an upload, or you tried to upload a file that is too large "

The image is definitely not too large, and I have selected it using the upload button.

I'm having real difficulties with the gallery function. I've added some sub-galeries, but can't see them. Any ideas? Must they have picturesin to see them? If so, then I really need to sort my uploading problem.

Running 4.2.2

Thanks.
Back to the top
 
Posted
Rating:
#57925
Avatar

Community saint

Dazed and Confused said

I've added some sub-galeries, but can't see them
It may be in

'Setup/Configuration/Feature Options/

that the 'Show empty galleries' box is not ticked.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#57931
Avatar

Well-settled

Thanks - that solved it.

My upload problem is still there.  I've worked out that it's IE8.  Firefoxlets me upload fine.
Back to the top
 
Posted
Rating:
#57937
Avatar

Community saint

IE ...grrrrrr


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#57945
Avatar

Hi,

Yes, there was a serious bug we had on IE8 with this. The fix may be in the bug fixes linked from your Admin Zone front page, if not let us know.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#57948
Avatar

Well-settled

Hi,

There is nothing about galleries or IE8 mentioned in the link.  Only Catalgues, Javascript in chatrooms and http authentication.
Back to the top
 
Posted
Rating:
#58252
Avatar

Community saint

Dazed and Confused said

You did not provide an upload, or you tried to upload a file that is too large
I find this happening in Foxfire and IE8 when I select the PREVIEW button while uploading a picture into a gallery.

As in the case of Dazed and Confused my action did neither of the warning issues. I used the built-in uploader feature in the ADD IMAGE function and the image was only 30.3kb.

…and thus far, I have not found a relative post in the Forum using the expanded search feature.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#58273
Avatar

Hi,

I couldn't justify the time to go back to the original issue as 4.3.0 was imminent, with the problem fixed – so friendly you've confirmed this is now fully working :).

However there is a separate issue that I was not aware of with the previews. This will be fixed in 4.3.1, or the fix below should work.

Attachment
themes/default/templates/JAVASCRIPT_SWFUPLOAD.tpl
» Download: JAVASCRIPT_SWFUPLOAD.tpl (77 Kb, 192 downloads so far)





Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#58345
Avatar

Community saint

This fix does work. I do notice that when I click preview button there is a strange blink or little flash and then the preview rolls down. Anyway it works.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: