HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Block email attachments

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#44380 (In Topic #9842)
Avatar

Well-settled

Chris,

I would like to disable the option for site users to send attachments to other site users who accept email. Can you direct me to the file and code that generates that option?

At least for now, I prefer they only have the ability to send plain text mails.

Much appreciate your assistance
Back to the top
 
Posted
Rating:
#44382
Avatar

Hi,

There's no easy answer to that. It'd be a job for a programmer.

You can stop emails entirely though if you want. You can restrict access to the contactmember module to do that.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#44386
Avatar

Well-settled

Ok, understood. Is there not a way to comment out the script that generates the table containing the upload box? That would be sufficient for now of possible (I just don't know the name of the file)

One more question…I seem to be unable to find the option to expand access to emoticons (so users can choose among all available rather than the 4 now displayed)

Can you point me towards that configuration option?

Thanks for all your assistance…
Back to the top
 
Posted
Rating:
#44396
Avatar

Community saint

Couple ways you can do that HSL.

Easy way:

phpMyAdmin, find the xxx_f_emoticons table, Select the browse tab.



Select the smiles you want to edit either individually or all on the page, Select edit.



Lastly change the highlighted values in the next screen shoot. options are 0 (do not show),1 (show) ,2 (not sure heh)

Once all the values are set, at the bottom of the page select save and go. This way is much quicker because you can edit many at one time.




The hard way:

Admin>Style>Emoticon>Edit

Then change the relevance level and check use for topic or is special depending on your needs. I would do this first with a couple anyhow to get a feel for what setting you need to make in phpMyAdmin. This way is just slower but acheaves the same thing because you need to do each individually.

Hope this helps.

ocP Ver 4.1
Back to the top
 
Posted
Rating:
#44399
Avatar

One more question…I seem to be unable to find the option to expand access to emoticons (so users can choose among all available rather than the 4 now displayed)

Edit each one (Admin Zone > Style > Emoticons) to change the settings.

Ok, understood. Is there not a way to comment out the script that generates the table containing the upload box? That would be sufficient for now of possible (I just don't know the name of the file)

I haven't looked at this screen in a while, I forgot how it works! I was thinking it worked via attachments, but no it has a special upload field. We can turn off the upload field via a template edit. I haven't tested this but try changing FORM_SCREEN_FIELD to:

Code

{+START,IF,{$NOT,{$AND,{$EQ,{NAME},{!_ATTACHMENT}},{$MATCH_KEY_MATCH,site:contactmember}}}}
...
{+END}

Where "…" is the current contents of the template.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#44407
Avatar

Well-settled

Chris and Sledge,

Thanks greatly for the assistance!
Back to the top
 
Posted
Rating:
#44415
Avatar

Well-settled

Having an emoticon issue

Ok, apparently I'm getting javascript errors at the 'edit emoticon' screen with both FF and IE7

0: Script error
javascript:alert('TODO:FIXME')


This is making it not possible to individually edit emoticon settings.

What happens is that in the forum area, a user can't select an emoticon from the displayed row when creating a topic, from the row that is above the text area. Below the text area is but a single emoticon, which can be selected.

I've gone to the db and each emoticon is - relevance level = 1 / use_topics = 1 / is_special = 0

Then clear block/template/theme in 'tools', still no go.

Any suggestions?
Back to the top
 
Posted
Rating:
#44417
Avatar

Well-settled

Update - ok changed relevance level and row at bottom of text area now includes the selected emoticons that insert properly. There is still a row above the text area I'd like to not be there (they don't appear to do anything, they do not insert from there).

Does anyone know the setting to make the emoticons above text area go away?

Thanks
Back to the top
 
Posted
Rating:
#44425
Avatar

Hi,

The emoticon selection code in 4.0.5 is a bit buggy in some places and we're going to fix this very soon now.

The 'row above' is the emoticon for the topic itself. I'll make that a bit more clear in the next release.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#44448
Avatar

Well-settled

No problem Chris, thanks for the info.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: