HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Bailing out because of PHP memory

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#94334 (In Topic #18811)
Avatar

Community saint

Hi,

After going live today with vwgolfmk1.org.uk I have had a few instances of this error. I have reported one of them in the bug tracker. http://ocportal.com/tracker/view.php?id=958

Just found another one so I thought that I would post up about it here.

If you enter the chat section and as an admin select "Chat System Moderation Page" it bails out as well.

I did try this in OcCLE but it did not seem to have any effect and it still bailed out with the same memory size error and top did not see a memory usage increase.

http://ocportal.com/tracker/view.php?id=506

Can some one definitively explain how I permanently raisethe PHP memory please ?

So far the majority of the feedback on the site has been brilliant - thanks OCP !!

Cheers
Ade

Back to the top
 
Posted
Item has a rating of 5 (Liked by Lhasadreams)  
Rating:
#94335
Avatar

Community saint

Lhasadreams said

  • 1. Can some one definitively explain how I permanently raisethe PHP memory please ?
  • 2. If you enter the chat section and as an admin select "Chat System Moderation Page" it bails out as well.
1. If you have access to your php.ini file on your hosts' server, then it is a piece of cake. However, they may take a dim view of this being raised on a shared hosting plan. But it you don't try, you'll never know!



2. Can't access 'admin' areas of the site, so can't see what you are referring to, but the next time you are troubleshooting this, have a look at your URL and if it is a HUGE string of nonsensical c**p, clear your browser cache and things should go back to normal.




 :offtopic:

Looked at the site, and it is turning into a work of art. Clean and easy to navigate. Noticed your banner header was displaying white space either side of the logo so, being a brash sort of guy, I fiddled a bit with it in Chrome's dev tools. Here is a graphic image, for what it's worth, and which you may or may not wish to use. If you do, it is self-explanatory …



 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#94342
Avatar

Community saint

Hi Fletch,

Thanks for this information.

I like the colour change either side of the header - thanks !!

We are on a dedicated server so I have full root access :-)

I made the changes to the memory allowances to 128MByte and OCP still reports that the 64Mbyte limit has been reached :-(

I tired Chris's OcCLE trick in the fix note but It made no difference.

OCP still thinks it has 64MBytes to play with not 128 - any idea how I can tell OCP ?

I can get it to bail out every time by asking for all of the paid members usergroup to be returned. Playing around it copes with a 820 request, but anything higher causes a bail :-(

Cheers
Ade
Back to the top
 
Posted
Rating:
#94344
Avatar

Community saint

Lhasadreams said

I made the changes to the memory allowances to 128MByte and OCP still reports that the 64Mbyte limit has been reached :-(
Setting the memory limit with OcCLE only changes the limit within ocPortal and does not change the php limit.

Check that php.ini has "memory_limit = 128M".

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#94345
Avatar

Community saint

Hi,

The limit is set in the php.ini file.

Just to be sure that I have the right php.ini

php -i | grep ini
Configuration File (php.ini) Path => /usr/local/lib
Loaded Configuration File => /usr/local/lib/php.ini

But at the bail out OCP still reports 64MBytes.

How can I tell what OCP thinks the limit is?

I restarted the Apache web server to pick up the new values.

Really quite stumped now :-(

Cheers
Ade
Back to the top
 
Posted
Rating:
#94348
Avatar

Community saint

1. Admin Zone » Setup » Configuration » Site options »Upload

ocP tells you what your post_max_size and upload_max_filesize values are. I know ocP actually reads the server's php.ini file, because I had lower figures before I changed the values manually on the server.

The other point, raised by temp, is to double-check that the memory-size reflects your changes.

2. Same info can be gleaned via  Admin Zone » Tools »PHP info, but remind yourself that it is a direct mirror of your server-side php.ini, and that any changes need to be made on that file.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#94349
Avatar

Community saint

I expected there to be one in either /public_html or /public_html/yourdomain to act as an override.

Creating one in either of those places should guarantee that it gets picked up.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#94350
Avatar

ocPortal sets its own memory limit. I will look at this topic when I have the time but am currently flooded in topics and tracker issues.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#94351
Avatar

Community saint

temp1024 said

Setting the memory limit with OcCLE only changes the limit within ocPortal and does not change the php limit.
I just checked the code and it looks like ocPortal does now save the memory_limit to the php.ini file when you change it with OcCLE (I doesn't in the v7.x that I'm using).

This is indeed strange.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#94366
Avatar

Okay so recap…

Server's have a limit…

CGI servers allow override via custom php.ini files. Non-CGI servers (which is the majority) sometimes allow override via .htaccess files.

Different PHP versions handle overrides in different ways. Sometimes it's allowed, sometimes it's not, sometimes the master value works as a ceiling to what you're allowed to override to.

Some hosts (1&1 I know) have a custom version of PHP which lies about memory limits.

Suhosin / SuPHP has it's own memory limit settings, if you happen to have that installed.

ocPortal sets an internal limit of 64MB, even if set higher externally. The OcCLE command is supposed to override this.

Some CGI servers have a CGI/process-level limit which also can kick in.


I will take a look on your server if you want to grant FTP access.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#94375
Avatar

Community saint

Ok Chris I wil set up an FTP access tomorrow for you to take a look.

Cheers
Ade
Back to the top
 
Posted
Rating:
#94395
Avatar

Raising the memory limit in OcCLE worked, I just ran:

Code

:set_value('memory_limit','256M');
(there was no evidence of that command being run before, so there must have been some misunderstanding somewhere on that)

However, I have undone it because it shouldn't be needed. I'm looking into these memory exhausted situations individually now…


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#94397
Avatar

Community saint

Cheers Chris
Back to the top
 
Posted
Rating:
#94400
Avatar

Chat one fixed. I'm surprised nobody else noticed this before, but it's probably something to do with the order the caches fill up in.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: