HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


After fresh install, the Forums link is broken: results in code

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#64324 (In Topic #13871)
Bob

Non-joined user

Hi,
Following a fresh install today, when I click on the Forum link, I get a paragraph of code:

if [ -z "$1" ]; then if [ -e "sites" ]; then echo "On myOCP" else find uploads/* -exec chmod a+w {} \; fi fi chmod -f a+w persistant_cache persistant_cache/* safe_mode_temp safe_mode_temp/* themes/map.ini data_custom/fields.xml data_custom/modules/admin_backup data_custom/modules/chat data_custom/spelling/*.log data_custom/spelling/personal_dicts data_custom/spelling/personal_dicts/* *_cached *_cached/* themes themes/* text_custom/*.txt text_custom/EN/*.txt *_custom *_custom/* themes/*/*_custom themes/*/*_custom/* themes/*/templates_cached themes/*/theme.ini themes/*/templates_cached/* themes/*/templates_cached/*/* themes/*/css themes/*/css/*.css data_custom/functions.dat data_custom/errorlog.php data_custom/ocp_sitemap.xml data_custom/permissioncheckslog.php data_custom/modules/admin_stats exports/* data_custom/modules/chat/*.dat exports/*/* imports/* imports/*/* uploads/* pages/*_custom pages/*_custom/* pages/*_custom/*/* */pages/*_custom */pages/*_custom/* */pages/*_custom/*/* info.php 2>/dev/null if [ -z "$1" ]; then echo "ocPortal file permissions fixed" fi

I suspect that I have made an error during the installation. I would appreciate any advice that would point me in the right direction, as I am new to ocPortal - a product which looks excellent, by the way.

Best,

Bob


Back to the top
 
Posted
Rating:
#64325
Avatar

Hi,

Please load up /upgrader.php, log in, and do an integrity check. Something hasn't transferred right.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#64327
Bob

Non-joined user

Hi Chris,

Thanks for coming back to me so quickly.

Upgrader.php gave me the following report:

These files are outdated:

-forum/index.php
-data/sounds/t.wav

The following alien files were found in ocPortal and possibly should be deleted:

data.ocp

*******

I suspect that forum/index.php is corrupted and needs replacing. But the data.ocp status as an alien file puzzles me. What do you think?

Best,

Bob
Back to the top
 
Posted
Rating:
#64328
Avatar

yes, data.ocp is from installer and not needed so can be deleted


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#64330
Bob

Non-joined user

Hi Chris,

Just wanted you to know that I replaced forum/index.php (as well as data/sounds/t.wav) and that resolved it - I can now access Forums via the Forums link.

Upgrader.php is a very impressive tool.

Thanks very much for your help.

Best,

Bob
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: