HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS. ocPortal 9 is superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


A suggestion for the CEDI

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#27533 (In Topic #6345)
Avatar

Well-settled

Maybe there's a way to set the permissions for the whole CEDI but I haven't found it yet.  As it stands I have to go into every page made and make it visable and editible by others using it.  IF there's a way to modify the default settings for the CEDI that would be fine but I would even be happy with either an "Inherit Permissions" option or a Edit Tree Permissions option.  Having to go in and change all the user groups just so they can see the posts is a bit of a hassle.

Thanks
Geo
Back to the top
 
Posted
Rating:
#27534
Avatar

It sounds like you don't have global submit permissions. To override for the whole CEDI module, I believe you just edit the permissions for the cms_cedi module (or possibly the cedi module – I can't remember off-hand) in the Permission Tree Editor.
I'm surprised if there are no view permissions by default though.


Become a fan of Composr on Facebook or add me as a friend. Add me on on Twitter. Support me on Patreon
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about Composr whenever you see the opportunity or support me on Patreon.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying Composr on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#27535
Avatar

Well-settled

Well i found the CEDI permissions and that fixed the defaults issue.  However the view access is set to View in the Permissions but not in the CEDI.  Any ideas?
Back to the top
 
Posted
Rating:
#27536
Avatar

View permissions aren't inherited in any way, but I'm surprised they aren't defaulting to 'on'. Infact, I've investigated, and now I can see that when you create new pages via tree editing, the permissions aren't set properly. I'd completely forgotten about CEDI permissions (we added these in version 3), so please forgive my temporary amnesia – I wrote this stuff too ;).

A new cms/pages/modules/cms_cedi.php is attached.

Attachment
» Download: cms_cedi.zip (4 Kb, 173 downloads so far)


Become a fan of Composr on Facebook or add me as a friend. Add me on on Twitter. Support me on Patreon
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about Composr whenever you see the opportunity or support me on Patreon.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying Composr on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#27547
Avatar

Well-settled

Well that fixed the CEDI so that it's set to automatically make things visible.  Thanks alot.

On the other hand setting the CEDI permissions in the Permissions Tree Editor doesn't seem to change the permissions in the CEDI itself.
Back to the top
 
Posted
Rating:
#27548
Avatar

Well-settled

Nevermind. I think I just had to reset my browser.

Thanks alot.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: