HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


503 Service Unavailable message when trying to save work

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#64950 (In Topic #13971)
Avatar

Community saint

Every time I try to save a CSS change I am getting this message:


503 Service Unavailable

The server is temporarily busy, try again later!

When I refresh the page it does save the changes but this process is annoying and steals time. It seems that I have run into this problem before and Chris had a solution but I can't remember what it was.

Please help.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#64961
Avatar

Hmm, seems like a classic mod_security problem. ocPortal is sending some HTML to the server and Apache's mod_security thinks you're a hacker for doing it. Our recommended.htaccess has a bit of code to disable mod_security but I don't believe it works with their latest version; unfortunately there's really no solution I can propose, it's between the web host and the mod_security people for adding system restraints. I think if you explain to Elief they'll sort it out for you.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#64980
Avatar

Community saint

Chris Graham said

I think if you explain to Elief they'll sort it out for you.
OK, thanks I'll take it up with them.

I did swap the default host .htaccess with the ocPortal's recommended.htaccess which chased away those white page dead ends.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#64984
Avatar

Community saint

plain.htaccess with the added Suhosin script works fine for me in solving this issue.

Code

# Suhosin can cause problems on configuration and Catalogue forms, which use a lot of fields
php_value suhosin.post.max_vars "2000"
php_value suhosin.request.max_vars "2000"
php_value suhosin.cookie.max_vars "400"
php_value suhosin.cookie.max_name_length "150"
php_value suhosin.post.max_value_length "100000000"
php_value suhosin.request.max_value_length "100000000"
php_flag suhosin.cookie.encrypt off
php_flag suhosin.sql.union off
Back to the top
 
Posted
Rating:
#64992
Avatar

Community saint

I took this problem to Elief, my web host, and the problem went through several attempts at resolving it without sucess.

Here is the latest comment on the problem:

Elief Support Team said

Hello,

This is not a mod_security issue.
IT appears that your script is trying to increase PHP memory limit, and Suhosin is blocking that:

2010-12-01 00:57:19.279 [NOTICE] [76.104.219.185:2076-1#APVH_davidlfriend.com] [STDERR] ALERT - script tried to increase memory_limit to 4294967295 bytes which is above the allowed value (attacker '76.104.219.185', file '/home/davidlfr/public_html/data/javascript.php')
Script is trying to increase memory_limit to 4GB, which is way too much.
I would suggest you to try to contact developers and check this error with them.

eLief.com Support Team


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#64993
Avatar

ocPortal's htaccess sets the memory_limit to "-1", which suhosin misinterprets as 4GB. Please try changing that.

It's irritating because suhosin is a third-party PHP plugin that introduces bugs.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#65002
Avatar

Community saint

Chris Graham said

ocPortal's htaccess sets the memory_limit to "-1", which suhosin misinterprets as 4GB. Please try changing that.
What should it be changed to?


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#65010
Avatar

Community saint

Elief Support Team said

Posted On: 01 Dec 2010 4:39 PM

Hello, this has already been commented out. It should be the following now:
memory_limit => 128M => 128M
suhosin.memory_limit => 128M => 128M

Regards,
Rob H

eLief.com Support Team
…and my response is:
With all this the problem still remains as I described it when I started this topic.
Where do I go from here?


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#65012
Avatar

Community saint

friendly said

With all this the problem still remains as I described it when I started this topic.
The last changes Elief did to .htaccess must have done the trick. Once the changes were made and I cleared the caches the problem disappeared.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#65030
Avatar

Community saint

Hi Friendly!

Glad to hear your issue is finally solved!

I don't know why I did not have your problems after using my plain.htaccess with the added Suhosin script. I've tested that premise many times for each new site added since and it always behaved the same: 503 before and resolved immediately after setting up the plain.htaccess.

Can you share the Elief modified .htaccess with me, please?
Thanks,
Jean
Back to the top
 
Posted
Rating:
#65035
Avatar

Community saint

Jean said

Can you share the Elief modified .htaccess with me, please?
All the modifications I can detect a change in were at the top of .htaccess so here are the top lines of ocPortal's recomended.htaccess

Code

# Disable inaccurate security scanning (ocPortal has it's own)<br />&lt;IfModule mod_security.c&gt;<br />SecFilterEngine Off<br />SecFilterScanPOST Off<br />&lt;/IfModule&gt;<br /><br /># ocPortal needs uploads; many hosts leave these low<br />php_value post_max_size &quot;16M&quot;<br />php_value upload_max_filesize &quot;16M&quot;<br /><br /># Turn insecure things off<br />php_flag allow_url_fopen off<br />php_flag register_globals off<br /><br /># Put some limits up. ocPortal is stable enough not to cause problems- it'll &#111;nly use higher limits when it really needs them<br />php_value memory_limit &quot;-1&quot;<br />php_value max_input_time &quot;300&quot;<br />php_value max_execution_time &quot;30&quot;
and here is how is how it is after Elief's modifications

Code

SecFilterEngine Off<br />SecFilterScanPOST Off<br /><br /># Disable inaccurate security scanning (ocPortal has it's own)<br />SecFilterEngine Off<br />SecFilterScanPOST Off<br /><br /># ocPortal needs uploads; many hosts leave these low<br />#php_value post_max_size &quot;16M&quot;<br />#php_value upload_max_filesize &quot;16M&quot;<br /><br /># Turn insecure things off<br />php_flag allow_url_fopen off<br />php_flag register_globals off<br /><br /># Put some limits up. ocPortal is stable enough not to cause problems- it'll &#111;nly use higher limits when it really needs them<br />#php_value memory_limit &quot;-1&quot;<br />php_value max_input_time &quot;300&quot;<br />php_value max_execution_time &quot;30&quot;
The changes are commenting out certain lines plus the first change I made at the direction of Elief which was the removal (I probably should have commented out instead) the lines "<IfModule mod_security.c>" and "</IfModule>"

Why the duplication the "SecFilterEngine Off" and the "SecFilterScanPOST Off" lines are beyond me unless they didn't look a couple of lines down and see them there already.

I guess for me it resolved the current problem. As to what the future impact of the changes may bring I have no idea.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#65040
Avatar

Community saint

Thanks, friendly!:)
Back to the top
 
Posted
Rating:
#65041
Avatar

Community saint

Anytime! :P

I looked at my prehistoricsillustrated.com site and .htaccess is similar to what Elief did for my new site.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: