HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


5.0.3 admin errors

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#66744 (In Topic #14232)
Avatar

Honoured member

Hi,

I got an error while in Admin Zone hitting the 'continue' button after no changes in a setup form. I thought I did change it, so hit it to be certain, but later I realised me I didn't change anything. This happens often when saving empty things strings values etc. to empty wrong/error strings or values in ocP. My programmers experience (45 years back when we need a room to put one (1) computer in it, hit it with a few boxes with punchcards 80 column to (RPG) program it, to count 1+1) say that its maybe an idea to auto-fill empty strings/values to prevent this error on several places, butits maybe a stupid thought from me. No trace, sorry.

I got an error while in Admin Zone hitting the 'continue' button in 'Adept Profiel Field statistic data' (freely translated from dutch):
Programming error: Integers and/or floats should not be passed into templates (VAL): convert them to strings.
See the stacktrace below:
Attachment
» Download: stacktrace_Admin_Z_trace_error.txt (9 Kb, 133 downloads so far)


I got an error while in Admin Zone hitting the continue button in uninstalling addon:
Critical error - bailing out
This is an error that has been elevated to critical error status because it occured during the primary error mechanism reporting system itself

(possibly due to it occuring within the standard output framework). It may be masking a secondary error that occured before this, but was

never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.
A language file for language EN is missing: ecommerce (version: 5.0.3, PHP version: 5.2.17, URL: /ocp/adminzone/index.php?

page=admin_addons&type=_mult

There is no problem as I uninstalled ecommerce and shopping before, but the error shouldn't be here because the program can "see" that its uninstalled. So > if the depended addon = uninstalled the reporting missed lang file is not needed.
Attachment


I got an error while trying to solve some errors above, reinstalling the missing langfiles by installing the addons, but that wont work obvious as the files are removed (I think), so a solution could be to change the filename of the langfile (maybe by using the GID Apache) and not remove them, so the files are available when reinstalling the addon.

Greetings Puran


Last edit: by Puran

21-7-1955 - 24-10-2011 I hope she rest in peace and I hope to see you soon.  Puran
Back to the top
 
Posted
Rating:
#66757
Avatar

H,

I think v6 solves the bulk of this.

To summarise:

  1. Error when making no changes on an edit
  2. Error in CPF stats
  3. Error with language file dependencies / Addons not split up correctly


I'd need to know what form for '1'. If it still happens reproducably on v6 please let me know.

'2' is definitely fixed.

In v5 there were a few issues with the addon dependencies not being correctly managed that are fixedin v6. I can see one specific class of problem though with how block caching works that I am going to resolve now. Emptying the block cache may help you, but also putting the .ini files back from the manual installer should hel too.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66764
Avatar

Honoured member

Hi,

Chris Graham said

I'd need to know what form for '1'. If it still happens reproducably on v6 please let me know.
The errors where on 5.0.3.

Chris Graham said

'2' is definitely fixed.
Thanks!

Chris Graham said

In v5 there were a few issues with the addon dependencies not being correctly managed that are fixedin v6. I can see one specific class of problem though with how block caching works that I am going to resolve now. Emptying the block cache may help you, but also putting the .ini files back from the manual installer should hel too.
In knew there where errors on v5.0.3 with addon, but I did see something about version 5.1 in advance so I thought then it must be working. Also I'm creating v5 + v6 of my site so I must lose those addons somehow. Would be better to never got them installed.

Now I have some theme probs, but first I have to leran, but ;little time. I want the fusion template (on Stichting Easwaramma - Nieuws set over to ocPortal.
Greetings Puran.

21-7-1955 - 24-10-2011 I hope she rest in peace and I hope to see you soon.  Puran
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: