HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[SOLVED]Enable Short URLS issue.

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#104091 (In Topic #20345)
Avatar

Community saint

Ok so I have a resellers account through Arvixe.  A client Site I have just loaded into it I wish to enable short URLS but it errors every time. I figured it was an Arvixe issue because I have short urls working on the parent site of my account with no issues and I figured it must have something to do with the clients site being a sub account type thing so I put in a support request to have them look into it. After seceral days of waiting for their response they finally said this:

Not making any progress with this issue - looks like a re-installation of your OCPortal site is inorder.

This sounds a little bogus to me. I have v9.13 installed with all 21 bug patches applied. (I know 9.14 just came out but I see no more confirmed bugs for 9.13 so I assume it is just a rollup of the already applied bugs)

I was going to add a stacktrace here (which I found very unhelpful) but now the site is down completely with a server not found message so I don't know what they did at Arvixe but it was working fine (other than short url issue) before I put in my support ticket to Arvixe.

Ok so now it is back up (last 10 minutes wouldn't work but now it is) so here is stack trace:

Code

Stacktrace removed


Last edit: by Duck
Back to the top
 
Posted
Rating:
#104092
Avatar

Community saint

Going through the upgrader now. File integrity scan shows many missing files so wil fix all those first and report back
Back to the top
 
Posted
Rating:
#104093
Avatar

Community saint

ok so Upgraded and replaced all missing files after integrity check and still no resolution
Back to the top
 
Posted
Rating:
#104096
Avatar

Community saint

Ok I may have solved this. I have short URLS working now but unfortunately I now many of my prebuilt pages are giving 404's so still working on stuff. But to get short urls working I added the following rule to my htaccess:

Code

RewriteBase /~mysubaccountname/
and this enable short urls to start working. Let you know how the 404's issue go next
Back to the top
 
Posted
Rating:
#104097
Avatar

Community saint

Ok so just had to rebuild the links in the menu and 404's solved all good now.
Back to the top
 
Posted
Rating:
#104100
Avatar

Cool. Yes, RewriteBase is a pain. I wish Apache had a way to automate that setting.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: