HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[RESOLVED] xml sitemap not generated

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#109833 (In Topic #21758)
Avatar

Well-settled

Greetings

As my topic title reads, ocP appears unable to generate xml sitemaps for either of my 2 installations. Even after running  force_sitemap_generation.php, as directed in the SEO tutorial, the returned page reads 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

but nothing whatsoever shows below.

Any clues, please, as to what's amiss?

Thanks for reading!
Back to the top
 
Posted
Rating:
#109835
Avatar

Hi,

If running force_sitemap_generation.php redirects to the xml file, that implies it has worked. I can't think of any error condition that would happen with it still finishing and redirecting.

Well, I can, if all guest access to the site is locked-down.

Is the xml file 0 bytes on disk?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#109838
Avatar

Well-settled

Hi Chris,

Thanks for your reply! In answer to your question, the ocp_sitemap.xml file on my server is correctly populated with my guest-permitted URLs, and was successfully updated by my running the .php script. Perms are set at 0644. When it's opened via its page-source view meta link, there's no content, apart from that message. Does this suggest anything to you?
Back to the top
 
Posted
Item has a rating of 5 (Liked by RichT)  
Rating:
#109840
Avatar

Yeah, either the browser is not good at displaying XML files, or it's corrupt ;).

https://understanding-piano-technique.com/ocportal/ocp_sitemap.xml is displaying okay for me in Chrome, which I see you're using. But I am running the Chrome "XML Tree" plugin.

It's probably just Chrome not coming with XML Tree by default and that's confusing you. I think all other browsers display XML fine.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#109842
Avatar

Well-settled

Ah-ha, yes - I didn't realize Chrome install doesn't incorporate XML read-functionality. As you said, the file opened fine in Firefox, and now does so in Chrome having just added the plugin.

Very many thanks, Chris!
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: