HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[Resolved] Host upgraded to LiteSpeed causing problems.

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#104707 (In Topic #20437)
Avatar

Community saint

My host just upgraded to LiteSpeed Web Server and now I'm getting a the following SQL syntax  error:

Expand: Stack Trace Stack Trace

Changing PHP version (via PHP Selector ) to 5.2, 5.3 and 5.4 makes no difference..

I'm running ocPortal 7.0.1. Any help will be appreciated.



Last edit: by temp1024

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#104709
Avatar

They may have updated litespeed, but this is caused by a MySQL upgrade.

'get' became a keyword. We fixed this one a while back, but a quick hotfix is to rename the ocp_stats 'get' field to 's_get', and change references in sources/site.php. There are other references, but those are the main ones.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#104712
Avatar

Community saint

Chris Graham said

They may have updated litespeed, but this is caused by a MySQL upgrade.
Yeah, an SQL syntax error sort of gives that away, but their upgrade notification only talked about litespeed and phpSelector changes  :dry: .

Chris Graham said

'get' became a keyword. We fixed this one a while back, but a quick hotfix is to rename the ocp_stats 'get' field to 's_get', and change references in sources/site.php. There are other references, but those are the main ones.
Thanks Chris :thumbs:, I'll work on that along with another couple of problems that the upgrade caused.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#104713
Avatar

Community saint

Chris Graham said

'get' became a keyword. We fixed this one a while back, but a quick hotfix is to rename the ocp_stats 'get' field to 's_get', and change references in sources/site.php. There are other references, but those are the main ones.
F.Y.I. I've changed get to s_get in the following 6 places.

  sources/site.php (1x)
  sources/lookup.php (3x)
  adminzone/pages/modules/admin_stats.php (2x)

and that seems to be all of them.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: