HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


(RESOLVED) Adding videos to galleries issue

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#99522 (In Topic #19558)
Avatar

Well-settled

Adding videos isnt working properly

I used to be able to add YouTube videos to my gallery without having to upload a representative image to go along with it, but for some reason lately it will not allow me to upload a video without also adding an image. This is making it difficult for my members to add videos of their own from Youtube. Do you have any suggestions on how I might be able to fix this?

Thanks in advance,
Mike Carlson (The LocalMC)
www.LocalMC.com
Back to the top
 
Posted
Rating:
#99527
Avatar

Hi,

I had a quick look at your site, and it says you're running 9.0.1. However, I couldn't see a fix we've made since then, so perhaps the issue still exists. I could not reproduce though. Could you give an example of a video that does not work? It might be our code doesn't recognise it as a Youtube URL.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#99528
Avatar

Well-settled

Can I give you a login username and password so that you can test the issue? I have the "add video" function locked out for guests.

Once logged in you can try to add a video under the "ADD CONTENT" link in the main nav at the top of the page. If you enter a Youtube URL and title it will not allow you to add the video until you select a representative image to go with it.

Before I had this issue members were able to only add the youtube URL without an image added and the system accepted it just fine.

Let me know it you'd like to try and test it if you have time. Any help would be appreciated.

Sincerely,
Mike Carlson
Back to the top
 
Posted
Rating:
#99532
Avatar

Got it, fixed.

There was some outdated logic in the code.

The logic said "you need a thumbnail on the form, unless you allow audio videos [which will use a standard thumbnail]; we therefore will force you to specify a thumbnail unless you have the option for audio thumbnails enabled, in which case we will defer the check until after form submission".

This did not take into account that Youtube ones do in-fact not need a thumbnail specified either, as we can pull it down from Youtube.

I have simply made the thumbnail field non-required. If it found it did need one, it will complain after the form is submitted.

It probably worked before as you probably allowed audio videos before.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#99533
Avatar

Well-settled

Thank you so much! I just tested it and everything is working fine again. As always, I truly appreciate all that you do for us :)
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: