HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


RSS/Atom stream failing

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#94128 (In Topic #18777)
Avatar

Community saint

Helping a member with setting up his site. I noticed that he has v9.0.1, which is what was installed for him via his host. No 'biggie', and easily fixed with an upgrade, BUT, also noticed that his RSS/Atom stream appears to be broken with an error message that isn't clear enough to me.

Who is the 'host' referred to in the smaller error message, and who is refusing the connection?



All helpful observations could earn a Santa visit …!!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#94129
Avatar

Community saint

It looks like you are trying to connect to ocPortal and ocPortal is refusing the connection.

Steve
Back to the top
 
Posted
Rating:
#94130
Avatar

Yeah. "Connection refused" is bubbling up from PHP, so it's not quite our error, I find it an unhelpful one too.

It doesn't necessarily mean that the server is explicitly denying to provide access to a service, which is what the message always looks like. It just means a connection tried to be opened, and something stopped it being opened - maybe because there was no end-point, or because there was a firewall, or yes there could be a ban.

However I think in this case the most likely explanation is a firewall or proxy on the main web server. Some web servers don't allow outbound HTTP connections that aren't whitelisted (annoying!), or sometimes (very rare for something outside an enterprise LAN) you need to channel requests through a proxy (ocPortal has some hidden options to allow for that).

This OcCLE command could help:
:set_value('prefer_curl','1');

This makes ocPortal use CuRL instead of it's own HTTP downloader, and that may have been specially configured or non-restricted somehow.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#94144
Avatar

Community saint

This OcCLE command could help:
Tried it. Didn't work. But thanks.

Will get our mutual member/friend to ask his web hosts to investigate. It is probably a set-up screw-up on their server that will clear the issue once they've identified it.

bummer

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: