HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Forum submission errors

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#75522 (In Topic #15637)
Avatar

Fan in action

I started setting up shop in the forums area of my site yesterday when I noticed a couple of glitches. Note that these appeared before making (at least knowingly) any changes to the configurations for the forums.

When I start a new topic, submit a reply or edit my post, the screen after submitting it is blank.

If I look through certain logs, the entry is reported as a "forum submission error."

If I then go back to the forum menu, I notice thad there is always an increasing number of copies. First time there were two, then there were three and with my latest test-topic, there were six copies. No, i did not hit submit more than once on each occasion.



So far, I haven't been able to find any documentation or forum posts regarding this.
Back to the top
 
Posted
Rating:
#75527
Avatar

I don't believe there is any "forum submission error." that ocPortal can generate. What exactly is the error message, and what exact log?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#75572
Avatar

Fan in action

I take that back…the "error submission log" was actually the title of the forum post I was using as a test, it showed up under the 'action logs', hence the confusion.

So by taking that out of the equation, I still get a blank page when submitting a new forum topic or a post and, when starting a new topic, it multiplies itself many times over.
Back to the top
 
Posted
Rating:
#75573
Avatar

Hi,

If you want to give me server access to debug this (something that will let me save, e.g. FTP), please send to chris@ocportal.com.

Otherwise, more questions…
  1. Does it sit around quite a while before going white?
  2. Are there maybe a lot of users who could be receiving tracking notifications?
  3. Anything in ocPortal's error log?

Chris


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#75574
Avatar

Fan in action

Thanks Chris, will do.

I just attempted to create a new topic and, for the first time, it was successful. I tried it again and it worked..the difference being that I was using Chrome this time. Then I went to trash the duplicate topics (batch delete) and was once again left with a lovely white screen. Refreshing the screen shows that the delete was not successful and there was a considerable delay before the screen appeared. I tried a second time using "delete topic" and this time, it worked.

Trying the same thing on Firefox…

It's taking a considerable amount of time and returns a white screen. After returning to the general chat menu and refreshing it, I have seven copies of the same post.

Going to see what happens in MSIE…

…and I can't even log on…this is after having logged out of the other two browsers for good measure.

As to your questions:
Does it sit around quite a while before going white?
Are there maybe a lot of users who could be receiving tracking notifications?
Anything in ocPortal's error log?

Yes, it takes a while before going white.
It's a brand new site that has not even launched yet so the only ones accessing it are myself and a partner.
Nothing in the error logs. Last recorded error is Sept 21, I only started going through the forums on the 26th.
Back to the top
 
Posted
Rating:
#75712
Avatar

Hi,

Currently waiting about FTP access, as I'll need to debug (last post definitely makes it sound like a possible server issue). Just noticed you online and remembered this topic was still unresolved.

Chris


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#75713
Avatar

Fan in action

Chris Graham said

Hi,

Currently waiting about FTP access, as I'll need to debug (last post definitely makes it sound like a possible server issue). Just noticed you online and remembered this topic was still unresolved.

Chris


Hi Chris,

Sorry, I didn't mean to make you wait; I have a lot on my proverbial plate and temporarily pushed the issue out of my mind.

When you mean ftp access, do you mean through my host or trough the CMS? OcPortal is still very new to me and am only now starting to fully comprehend how the various components were fit together.

Regards
Back to the top
 
Posted
Rating:
#75714
Avatar

Hi,

No problem, I just wanting to make sure you weren't waiting on a reply I couldn't yet give.

Through the host, so I can possibly make changes to the ocPortal code.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#75834
Avatar

Well I finally got to the bottom of it. There was something called 'Varnish' (a cache) on the server, and ocPortal was displaying a '404 error', and Varnish 'cached' the error message (because it doesn't think 404 errors need to be displayed accurately), but as the server was slow by bad luck it only had cached part of it (i.e. cached it as corrupt, which is the white screen you saw).

So it was a combination of:
  1. An ocPortal bug (selecting multiple topics to trash from the forum index – not something people do much so nobody noticed it wasn't working)
  2. A very slow server that sometimes gave incomplete pages / The ocPortal caches disabled
  3. The error message giving a 404 error & Varnish caching displayed 404 errors

That was pretty hard to figure out ;).

Generally though the problem was that the ocPortal caches were off. Everything else just either made it harder to debug, except the little ocPortal bug we found, which in a sense actually helped solve the problem as it made a reliable test case for reproducing the white-screens.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#75841
Avatar

Fan in action

Thanks Chris
I had the caches turned off because I was still actively setting up the site–I never thought it would create that much chaos–other than slowing it down.

My hat is off to you. :)

I've been looking into new servers for a while as I haven't been very happy with them for quite some time. I feel that until I am up and running and can gauge the traffic response, I might as well stay put. After that, if it picks up (as I fully expect it to), I'm considering placing it on a VPS.
Back to the top
 
There are too many online users to list.
Control functions:
 Add topic 

Quick reply   Contract

Your name:
Your message: