HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[Solved]Activity feed strange behavior

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#97785 (In Topic #19348)
Avatar

Community saint

Hi Guys, I installed the activity feed addon in version 9.0.7
It looks good working, but after some tests I see nothing coming up in the main box on the frontpage. If I write something in the Status Upgrade it showing up in the profile activity, but not in the activity feed in the frontpage. Also under Tab Notifications I can't select anything.

What have I done: translated some text to dutch after install not more then that.
I also see that the feed is double all the messages….:(

Some has a idea why this is happen?

Harry

This is my profile page activity The same text should also there on the main activity block (frontpage stays empthy).


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97786
Avatar

Community saint

Oke found out that I had the Chat addon not installed. Because the chat is not working to me. Need a new post for this. But the Notification on the frontpage is now working.

For the double posts I have to wait if this is come again.


Harry


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97787
Avatar

Community saint

Oke the double posts are there see my picture..




Update:
The text is not updating itself… need to refresh the page to see new entry

So here I need some help of the designer :)


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97794
Avatar

Community saint

Oke after chat problems are solved, it solved also the refresing (ajax) problem. Only that the text doubled itself with some change after some time stays.

I can't find anything what triggered this.



Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97800
Avatar

Community saint

Very strange things happened here with this addon. This morning I started the site on and I see that there was something changed on the status upgrade section…. my button was minimalized, also the text "public" is white… This was also in the profile, the tab is almost gone.  See my pictures for a more visual…



Update, ajax again not working. Need refresh the page before new message is visible. :(


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97820
Avatar

Community saint

I've had the same problem with the status not updating.

Harry, what settings are you using for "mode" and "member" in your main_activities block? I'm using this block on my front page and forum to post system notices to members. It's working ok for me. Try leaving "member" and "mode" blank if you have not already tried that.

Steve
Back to the top
 
Posted
Rating:
#97826
Avatar

Community saint

Thanks Sholzy.
Member was empty already. Have now also mode as empthy and a test give a good result.  :thumbs:


Update:

But after een second test its not working again. I think there is more checks needed to get this 100% good working.  :(  :(





http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97828
Avatar

I will look into this for you properly Harry. It may be today, or tomorrow. Sorry for the delay I've been ill/out a lot in the last week.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#97829
Avatar

Community saint

No problem Chris... We have all sometimes other things to do... hope you can find the trigger to this one. :)


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97856
Avatar

Community saint

After fresh install 10 minutes ago, the same text double is there.... pfffff


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97859
Avatar

If I write something in the Status Upgrade it showing up in the profile activity, but not in the activity feed in the frontpage

I have tidied up the block assistant for the main_activities block to make it easier to use.

I have done a full code review of the PHP file that handles all the activity querying, as frankly it was a bit of a mess (written in a tight deadline by too many different developers). I've largely rewritten it, which makes it a bit easier should be decide to make activities a bundled addon in the future :).

I have debugged through all modes of the block and they seem to be working.

Also under Tab Notifications I can't select anything.

It only does has something to select if you have some friends; i.e. you can monitor for activities of individual friends from here. Or, if you manually monitored a member's activity feed (via the button on that feed), an option to un-monitor it will be in here.

I also see that the feed is double all the messages

This was previously fixed in a hotfix. I have applied that fix.

Also – I removed your customised ACTIVITY.tpl, as the latest version (not released yet - but I've provided to you) has the translation for the code change you'd used (taken from one of my forum posts) in the language file itself.

my button was minimalized, also the text "public" is white

This is the same thing - apparently the language file being corrupted. I can't say what it was because you reinstalled, but perhaps you had accidentally broken something in there when doing translation. Or, perhaps somehow the language cache had corrupted and needed emptying.

ajax again not working

I note you also had various problems with chat but since resolved them. I'm not sure what these would have been, but it sounds like some kind of Javascript error came from somewhere and you had fixed it.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#97863
Avatar

Community saint

Chris I have to thank you for the time you have done to invest this all and make all the changes.

The chat problem I solved has to do witch a writing to file error, the rights were changed after transmission my domain to a another server, after change this back the chat was working. So this was the easy part to solve. :)

Harry..


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97866
Avatar

Community saint

Chris, I changed tree words in the activity language file to dutch, now I got the same problem… see my screenshot. It give that is missing language but also my status update changed.

Where can I got the original language file for this?



I'am sorry to bother you for this..

I changed these three words and back.
Says, has, ago.

Harry

UPDATE:
I have cleared all the caches, but nothing happend. I don't understand why translating tree words can have so great impact :(


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#97867
Avatar

Here is lang_custom/EN/activities.ini
Attachment
» Download: activities.ini (3 Kb, 128 downloads so far)


It seems there is a bug translating language files of non-bundled addons in ocPortal. It's removing any unedited strings.

Please edit this file directly and upload, I will look into the bug.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#97868
Avatar

Community saint

oke Thanks!


http://digiflash.nl Photo community  (dutch)
Back to the top
 
There are too many online users to list.
Control functions:
 Add topic 

Quick reply   Contract

Your name:
Your message: